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This hands-on computer training introduces participants to five
visualization tools built into Excel 2016: conditional
formatting; charts, pivot tables and charts, 3D maps, and
PowerView. These are out-of-the-box tools that require no addins.
We will also discuss some options for sharing the
visualizations. However, publishing interactive maps and views
requires the use of SharePoint software. That software and
process is beyond the scope of this presentation.
Data
• Download the data files from: https://tinyurl.com/y94o9vr3
• Open the worksheet: development-districts.xlsx.
The worksheet DDdata contains four years of data from the
American Community Survey 5-year estimates (2009-2013, 20102014, 2011-2015, and 2012-2016). Each line of data contains a
date, county, state, development district, and 16 additional
fields of data about population, housing, and economic
indicators.
To use the Excel visualization tools, data should be formatted
with one row of field names at the top and with no empty rows,
columns, and cells in the data. It is sometimes helpful to
filter the data before visualizing.
Filtering data
•
•

EXERCISE 1
Select the first row.
Select Data > Filter.

CONDITIONAL FORMATTING
Conditional formatting is one of the easiest ways to help the
user see patterns in the data or to bring attention to important
values in a large table of data.
•
•

EXERCISE 2
Filter Year to 2016.
Select the Population under 18 column.
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•
•
•
•
•
•
•

Select Home > Conditional Formatting > Data Bars > Choose
any option.
Sort the column smallest to largest to create a ranking.
Select the Population 65 and over column.
Select Home > Conditional Formatting > Color Scales >
Choose any option.
Select the Minority Population column.
Select Home > Conditional Formatting > Top/Bottom Rules >
Top 10%. Leave the default options. Click OK.
Select Home > Conditional Formatting > Top/Bottom Rules >
Bottom 10%. Change the options to Green Fill. Notice that
the previous Top 10% formatting is still there.

CHARTS
Simple Chart
Let’s create a simple column chart with educational attainment
information for a few counties.
•
•
•

Exercise 3
Open filter for County. Select a few counties.
Select the columns for Year, County, High school graduate,
and Bachelor’s degree.
Press F11. Note: F11 creates a chart in a new worksheet.
Alt+F1 creates a chart in the same worksheet.

Note that
currently
return to
worksheet

the data is grouped by Year because our data is
sorted by Year. To change the grouping to County,
the data worksheet, sort County by A-Z, select
columns again, and Press F11.

Note that the design ribbon is open. There are several functions
here that allows you to format or manipulate the chart.
•
•
•
•

EXERICSE 4
Open the dropdown for Quick Layout and move cursor over
each option to see how it changes the look of the chart.
Select one.
Open the dropdown for Change Colors. Select one.
Click on the different Chart Styles. Select one.
Click on Change Chart Type. The tab for All Charts will
open. Click through the different charts to see how each
would look.
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•
•

Click on the Recommended Charts tab to see which charts are
most appropriate for your data.
Select the Clustered Column Chart.

Combination Chart
•
•
•
•

EXERCISE 5
Open Change Chart Type.
Under All Charts tab, select Combo.
Change the Chart Type for Bachelor’s Degree to Line.
Select the first option under Line, also called Line. Click
OK.

Let’s add some additional formatting.
•
•
•

Click the title to change the text.
Double-click the legend to change the location and other
formatting.
To change text on the legend, return to the data worksheet
and change the field name.

Copying, Linking, and Embedding Charts
Charts can be either copied to, linked to, or embedded in other
documents. To copy, link, or embed, select the chart, then cut
and paste as usual, selecting the appropriate paste options,
which include whether to retain the formatting from Excel or to
use the formatting of the new document.
Copying creates a static image of the chart. Linking creates a
one-way link to the Excel worksheet to the new document. Changes
to the Excel worksheet will make changes to the chart in the new
document. Embedding the chart copies the entire Excel file into
the new document. To make changes to the chart, edit the data in
the new document. These changes will not be saved in the
original Excel file.
PIVOT TABLES AND CHARTS
A pivot table is a way to easily summarize and manipulate data.
For example, using a pivot table with our data, we can group the
counties together by Development District and look at data for
the district.
Pivot Table

3

•
•
•

EXERCISE 6
Go to Insert > Recommended Pivot Tables (in Tables group).
Look at the thumbnails of recommended pivot tables.
Click Cancel to close the Recommended Pivot Tables menu.

Instead of selecting a recommended table, let’s create our own
table of the change in the percent of population 65 years and
over by development districts over time.
•
•
•

Select Insert > PivotTable (in Tables group). This will
automatically select the entire range. This can be changed,
but don’t change it for this exercise.
Make sure New Worksheet option is selected.
Click OK.

On the right is a list of fields on the top with areas of the
table listed below. Drag fields from the list to the appropriate
areas to create a table.
•
•
•

Drag Year to Columns.
Drag Development District to Rows.
Drag Population 65 and over to Values.

Note that when we move a field to Values it sums the data, by
default. In this situation, we want an average not a sum so we
need to change the formula.
•
•
•

Open the dropdown of Sum of Population 65 and over.
Select Value Field Settings.
Select Average. Click OK.

Now that we have a nice summary table, we can create a chart
using the same steps as above.
•

Select range and press F11.

The chart can be formatted in the same way as other charts using
options under PivotChart Tools > Design and PivotChart Tools >
Format. Right-click on a field button to get an option to hide
them and for other options.
Note: Selecting PivotChart from Charts group will give you a
slightly different screen and menu options. But the same basic
procedures apply.
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3D MAP
As the name implies, this is a tool used to create maps. It is
located on the Insert tab.
Values Map
•
•
•
•
•
•

EXERCISE 7
Highlight the entire range on the DDdata worksheet.
Select Insert > 3D Map > Open 3D Maps.
o If a menu listing Tours opens, Select New Tour.
This shows a globe a field list, and a menu.
o If the field list is not visible, click on Home >
Field List.
3D Map may insert the location information automatically,
but if not drag County and State to Location.
Make the map bigger by clicking on + sign.
Data can be visualized in several ways. Click through the
icons under Data to see options: stacked columns, columns,
bubbles, heat map, and region.

Let’s make a map showing means-tested health insurance coverage
by county.
•
•
•
•
•
•

EXERCISE 8
Select Data > Region.
Drag Population with means-tested health insurance coverage
to Value.
Use the dropdown to change this from a sum to an average.
Drag Year to Time.
Use the dropdown to change the setting of Year to Year.
A motion bar appears at the bottom of the map. Click on the
go arrow to see how the values for each county changes over
time.

The color changes in the counties is very subtle since we are
using the region setting in Data. Let change it to a heat map to
see a more dramatic showing of the change over time.
•
•
•

EXERCISE 9
Select Data > Heat map.
Open Layer Options and change Radius of Influence to 250.
Click on the go arrow to see how the values change over
time.
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For maps with a time element, you can create an .mp4 videos of
the tour by clicking on Create Video. (Don’t do this now because
it does take a few minutes to complete.)
Category/Thematic/Choropleth Map
Instead of values, we can also map categories. Let’s create a
map of the Development Districts.
•
•
•
•
•

EXERICSE 10
Select Home > New Scene > World Map.
Drag County and State to location, if not already there.
Select Data > Region.
Drag Development District to Category.
Click the + sign to make the map bigger.

Formatting a map
There are lots of ways to format the map. Here are a few
options. Try a few.
•
•
•
•
•
•
•
•

Hover over a county and select the settings icon to edit
the data card (aka, tool tip).
Select Map Labels from the tool bar to add labels to the
background map.
If there is no legend, add it by clicking on Legend in tool
bar.
To edit title of legend, edit the Layer name in the menu,
using the pencil edit.
To change how categories are represented on legend, change
the shading of regions by clicking on the dropdown above
the category field fox and selecting no shading.
To resize and reposition the legend click on it. Then drag
to reposition. Use drag icons in the corner to resize.
To change text font, size, color, and attributes doubleclick legend.
Themes are available from the ribbon. Click on a few to see
what is available.

For any of the maps you can use the Capture Screen function to
copy a static picture of the current map to paste into another
document.
POWERVIEW
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PowerView is a data visualization technology that lets you
create interactive charts, graphs, and maps. It is available in
Excel 2013 and 2016. It is located on the Insert tab.
Note: It appears that Microsoft intends to continue supporting
PowerView in Excel 2013 and 2016. However, PowerView will not be
included in future versions and is being replaced by Power BI a
separate, stand-alone visualization and analytics product from
Microsoft.
Let’s create an economic profile for a county, with information
about housing costs, employment data, and poverty data. First we
create tables, turn those tables into visualizations, add
filters, then arrange them in the view.
•
•
•

EXERCISE 11
Click on the tab for the data.
Select the entire range.
Select Insert > PowerView.

PowerView may try to be helpful by creating a table. You can use
the field list to the right select and deselect the fields you
want on your table or you can start a table from scratch. Let’s
start a table from scratch.
•

Select and delete the table automatically created by
PowerView.

Create Employment Data Chart
•
•
•
•
•
•
•

Drag County to the view.
Select Labor force participation and Unemployment rate from
the field list.
Change the calculated field data from Sum to Average using
the dropdown in the fields box.
Select the table.
Select Design > Column Chart > Clustered Column.
Select Layout > Legend > Show legend at bottom
Select the chart and resize it smaller to make room for
other charts.

Create Poverty Information Chart
•

Create another table by dragging County to the view.
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•
•
•
•
•

Select Population below poverty and Population under 18
below poverty from the field list.
Change the calculated fields from Sum to Average.
Select the table.
Select Design > Bar Chart > Clustered Bar.
Select Design > Layout > Legend > Show Legend at Bottom.

Create Housing Cost Cards
•
•
•
•
•

Create
Select
Change
Select
Select

another table by dragging County to the view.
Housing cost to income ratio from the field list.
the calculated field from Sum to Average.
the table.
Design > Table > Card.

Filtering and Formatting View
Adding filters will make the view interactive.
•
•
•

Drag County and Year to the Filters area. These filters
will apply to all of the visualizations in the view.
Select a few counties.
Select a year.

Formatting the view will make it more appealing.
•
•
•
•
•
•

Resize and move the visualizations around the view until
they fit nicely.
Click on the title area to edit the title.
Close the PowerView Fields menu.
Select PowerView > Fit to Window.
Select PowerView > Themes to pick automatic formatting. Or
change the font, text size, or background.
Select Insert > Text Box to add instructions or other
information, then resize and reposition the text box.

8

How to Insert/Show 3D Map and PowerView on Insert Ribbon in
Excel 2016
Step 1
• Open File > Options > Add-Ins.
• At the bottom of the screen, using the Manage dropdown,
select COM Add-ins. Click Go…
• Check the boxes for Microsoft Power Map for Excel and
Microsoft Power View for Excel. Click OK.
Step 2
• Open File > Options > Customize Ribbon.
• Using the Choose commands from dropdown, select All
Commands > PowerView.
• Using the Customize the Ribbon dropdown, select Main Tabs >
Insert.
• Click New Group. Rename the group, if desired.
• Click Add. Click OK. The PowerView function should appear
on your Insert tab.
Repeat Step 2 for 3D Map.
You may need to restart Excel or your computer for these to show
on the ribbon. When you first use PowerView it may ask you to
install Silverlight and to click Reload. You make need to
restart your computer.
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